PreSonus Blog

Monday morning blues

March 12,2012

Well, it appears that one of my previous posts caused a bit of a storm in the media. While it’s nice to get attention I guess, I’ve taken down the post because it got perceived as being some kind of marketing blurb, when it wasn’t supposed to be. Yeah it’s true that I do marketing for PreSonus, but this isn’t the place for it. This is really just me talking about what I personally get up to with Studio One, not some kind of advertising spam. That’s why I started doing the Freebie Friday posts for example – those are plugins that I actually personally like and use to make music with – PreSonus doesn’t get anything out of me telling people about free stuff. My posts here are just me talking about the things I do and like, and that I think might be interesting for you guys too.

So my apologies to anyone that I might have offended with a previous post, but don’t blame PreSonus for it. Anything appearing in this blog under my name is my personal opinion only (that’s why it’s got my name on it) and certainly not some kind of company policy. So blame me, not them.

I got into this business because I love to make music, and I love technology, and even after many many years of doing it I still love it and get very enthusiastic about it. And I guess most of the people reading this feel the same way, so if I sometimes go a little overboard, I hope you guys can understand. I’m a musician first, and a marketing guy second, and it should stay that way. Thanks for listening.

Category Blog | 4 Comments ยป
Posted by rodney



4 thoughts on “Monday morning blues

  1. Having some problems here with Studio One sound. I’ve been all over the web for the last couple weeks and can’t get any answers. I can get Studio One working with ASIO4all v.2 but no others sounds work on the computer. Even if Studio One isn’t launched I’ve lost all sound to the computer. I’m ready to uninstall and just go back to Pro Tools for everything. Sooo frustrating.

Leave a Reply